Details - Printer Firmware Updater (Mac) for the PRO-10 Ver. 1.3a
ID: 0400065101_EN_6
This updater will upgrade your printer's firmware to version 1.110. To perform this upgrade, a USB cable and a computer are needed. If your printer's firmware version is already 1.110 or later, the update is not necessary. To check your printer's firmware version, refer to the Update Procedure included in the downloaded file.

How to Download and Install
Double-click the downloaded dmg. file to decompress it. Then, open the newly-created "Printer Update" folder. And open the Manual.html inside the language’s folder, then execute the update of the firmware based on the manual "Manual.html."
Driver/Software Details
File Name
mfuu-mac-pro_10-1_3a-ea7.dmg
File Version
1.3a
File Size
15.20 MB
File Languages
English | Spanish | German | French | Italian | Japanese | Chinese
Post Date
09/30/2014
Download and Installation Instructions
- Printer Update: The firmware to upgrade the functions of the printer.
- language’s folder: Contains the manual of the firmware update procedures. Launch it from Manual.html inside the language folder.

History
[Ver.1.3a]
- OS X Yosemite (v10.10) has been added as a supported OS. 

[Ver.1.3]
[ROM]
- The internal modules have been updated.

[Ver.1.2]
1.OS X Mavericks v10.9 has been added as a supported OS.
2.[ROM]
- The supported paper for printing via PictBridge connection is changed to "Photo Paper Pro Platinum N."
- "Photo Paper Pro Platinum N" is added as the supported paper for non-PC printing (Camera Direct printing and printing via PictBridge or Wi-Fi connection).

[Ver.1.1]
[Manuals]
- The following supported languages have been added: French, Spanish, German, Italian, and Simplified Chinese.

[Ver.1.0]
- The problem in which the ink level is not indicated properly in some instances has been rectified.
Environment
OS X Yosemite v10.10
OS X Mavericks v10.9
OS X Mountain Lion v10.8.5
OS X Lion v10.7.5
OS X Snow Leopard v10.6.8
OS X Leopard v10.5.8
OS X Tiger v10.4.11
Caution
- A USB cable & a computer are needed to perform this upgrade.
- See the attached manual to confirm the update procedures.
- Execute updating in the environment which you log onto as a member of the Administrators group.
Downloads are not available as your browser JavaScript setting is disabled. Please enable your browser JavaScript setting to download the file.