Web Content Viewer

Actions

SELPHY CP910 Blue

Contact Support

1-800-OK-CANON (1-800-652-2666)
Monday-Friday: 10:00 am to 10:00 pm
All times ET, excluding holidays.
Want to register this product?

SELPHY CP910 Blue

DISCLAIMERS


  1. Wireless printing requires a working Ethernet network with wireless 802.11b/g or n capability or a camera that supports DPS over IP. Wireless performance may vary based on terrain and distance between the printer and wireless network clients.
  2. AirPrint functionality requires an iPad, iPhone 3GS or later, or iPod touch 3rd generation or later device running iOS 4.2 or later, and an AirPrint-enabled printer connected to the same network as your iOS device. A printer connected to the USB port of your Mac, PC, AirPort Base Station, or Time Capsule is not supported.
  3. Requires Canon Easy-PhotoPrint for iPhone app, available for free on the App Store, Canon Easy-PhotoPrint for Android app available for free on Google Play, or Canon Easy-PhotoPrint for Windows RT, available for free in the Windows Store. Compatible with iPhone 3G, 3GS, 4, 4S, 5, iPad, iPad mini, iPod touch, Android devices running Android OS 1.6 or later, and Windows RT devices.
  4. Based on accelerated dark storage testing by Canon under controlled lighting, temperature and humidity conditions. Canon cannot guarantee the longevity of the prints; results may vary depending on printed images, display/storage conditions and environmental factors.
  5. Print speed obtained using compatible Canon compact digital camera incorporating DIGIC II other camera models may vary.
  6. Compatible memory cards include SD Memory Card, SDHCMemory Card, SDXC Memory Card. The following can be used with the addition of a special adapter sold separately: miniSD Card, miniSDHC Card, microSD Card, microSDHC Card, and MicroSDXC Card.
  7. Supports DPOF "Both" mode of both standard and index printing.
  8. System requirements vary by application. For Mac OS, an Internet connection is required during software installation. For Windows OS, .NET Framework 4 is required to install My Image Garden, Quick Menu, and Easy-WebPrint EX software.
  9. Warranty programs are subject to certain conditions and restrictions. See www.usa.canon.com/support for details.

† Prices and specifications subject to change without notice. Actual prices are determined by individual dealers and may vary.

 Return to Top