Web Content Viewer

Actions

CanoScan LiDE 600F

Contact Support

800-652-2666
Mon - Fri 10:00 am - 10:00 pm ET
All times ET, excluding holidays.
Want to register this product?

CanoScan LiDE 600F

DISCLAIMERS


  1. USB 2.0 Hi-Speed requires Windows XP, 2000 or Mac OS X operating systems. For Windows 98, Me and Mac OS X v.10.2 to 10.2.6 operating systems, the scanner will operate at USB 1.1 specifications.
  2. Systems with Pentium® III or higher, Celeron® (566MHz or higher), AMD: Athlon™, Athlon MP, Athlon XP or Duron are recommended.
  3. See www.canontechsupport.com for updated compatibility.
  4. System requirements vary by application.
  5. Latest Mac OS X Leopard driver available for doneload under the "Drivers & Downloads" tab.
  6. Warranty programs are subject to certain conditions and restrictions. See www.canontechsupport.com for details.

† Prices and specifications subject to change without notice. Actual prices are determined by individual dealers and may vary.

 Return to Top