Web Content Viewer

Actions
Canon Camera Connect Mobile Application

CAMERA CONNECT:

THE SINGLE APP FOR EOS, POWERSHOT AND VIXIA

 

 
Features Button
 

 
 
 
 

System Requirements

  Items Camera Connect Ver. 2.2.20
iOS Device Bluetooth®* 4.0 or later-equipped devices (above iPhone 4s, iPad 3rd, iPod touch 5th), smartphones and tablets compatible with iOS® 9.3/10.3/11.2**
Android Device Bluetooth®* 4.0-equipped devices, smartphones and tablets compatible with Android™ 5.0/5.1/6.0/7.0/7.1/8.0/8.1**
OS Version Install Guarantee of operation
iOS  9.3/10.3/11.2 Yes Yes
 9.0–9.2/10.0–10.2 Yes -
 8.4 or less - -
Android 4.4/5.0–5.1/6.0/7.0–7.1/8.0–8.1 Smartphone Yes Yes
Tablet Yes Yes
 4.3 or less Smartphone - -
Tablet - -
 Bluetooth®* Connection Android™ 5.0 or above
 

Available On

 
 

For Additional Help & Support, please click here.



See All Canon Apps

* For Bluetooth® connection, the camera needs to support Bluetooth® and the Camera Connect app needs to be the latest version.
** This application is not guaranteed to operate on all devices.